Loading SWF for the first time...
Adobe Flash is required to run this project in the browser. Enable Flash

WASD to move, mouse to shoot.

The Holo-lab's gone haywire, and history's greatest tools are running amok! GO BLAST 'EM!